Firewalla does not recognize network names Mash Deco M5

Comments

15 comments

  • Avatar
    Firewalla

    We have not personally tested with TP-Link Deco.  From what we know, after you have Firewalla running in simple mode, make sure the 'monitor' mode on the satellites are set to off.   See following  https://help.firewalla.com/hc/en-us/articles/360008005173-About-Mesh-Routers

    The reason when your main router working is,  you have router within router deployment.  When you attach to main router, you are looking at the TP-Link Deco as one device.  (via NAT). 

    So best is connect back Firewalla to the main unit of the Deco and turn off monitoring on the satellite. 

    0
    Comment actions Permalink
  • Avatar
    Jay “Jay-Son” Martin

    Unfortunately, I andy encountered this issue. I have the TP-LINK Deco M4. My Firewalla is connected directly to the main Deco router, not the satellite. However, every time Firewalla is on and running, traffic from the devices on the network never show within the TP-LINK app. It may display two or three, but other active devices don't show up at all even though they have internet activity. When shutting Firewalla off, all the wireless devices show up within the TP-LINK app. This becomes an issue when making changes to parental controls within the TP-LINK app, as they do not receive updates. Any suggestions?

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    This is very likely due to how TP-LINK App to track traffic + how firewalla is directing traffic.  If device tracking is done via DHCP services + IP, then shouldn't be a problem.  From what you have described, it is likely TP-LNK using ARP table, when that happens, it will likely be confused by firewalla simple mode.   Nothing really we can do, that's how their software works.  Best is just use firewalla to track devices.

    0
    Comment actions Permalink
  • Avatar
    Jay “Jay-Son” Martin

    Would there be any workaround or resolution I can do temporarily?  For example, right now Firewalla is setup with simple mode.  Should I change it to "DHCP" mode or "Expert" mode to get around this?  If not, could there be any future updates to resolve this?  I don't mind using Firewalla for all those needs, but options such as Device Priority aren't yet available.  Thanks.

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    What you can do is: (in theory it should work)

    1. Stop firewalla monitoring.  (disable it or change to limited mode)

    2. Your device list should become normal ...  then assign whatever priority you have

    3. turn monitor back on

    Or for individual devices

    1. devices->[device]-> scroll to the bottom and disable monitoring

    2. hopefully you will see that device in the app, then modify its priority

    3. turn monitor on

     

    0
    Comment actions Permalink
  • Avatar
    Jay “Jay-Son” Martin

    Thanks for the info.  For now, that does the trick.  Take care, and still loving this product!!!

    0
    Comment actions Permalink
  • Avatar
    Brian Moreno

    I just bought the Deco M9 and Firewalla is running in Simple mode just fine, however I'm having the same problem within the TP Link app where only a couple devices show up while Firewalla is monitoring.  When I turn off monitoring all the devices show in the TP Link app.

    It has been 9 months since the last post and wondering if there are any new answers or an actually fix for this.

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    The issue is when ARP spoof is activated (I assume you are using that mode),  some routers (software running inside them) that don't rely on DHCP, will likely get confused.  This is really a problem of the tracking code in the router, something we can't really 'fix'.    The best way is just rely on Firewalla for the device list, it is likely more completely. 

    0
    Comment actions Permalink
  • Avatar
    Michael R. Houser Jr

    I am also wondering if there has been a fix for this issue? Why would the TP-Link app show only a few devices?

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    This is something firewalla can't fix.  It is how simple mode works, and how the TP-Link app track devices.   The best way is to rely on Firewalla for device list.

    0
    Comment actions Permalink
  • Avatar
    Michael R. Houser Jr

    If I run the Firewall in DHCP mode would that help? I see this is an issue when making changes to parental controls within the TP-LINK app, as they do not receive updates. Any suggestions?

    0
    Comment actions Permalink
  • Avatar
    Michael R. Houser Jr
    Can I turn off ARP spoofing? Why use ARP spoofing, anyways?
    0
    Comment actions Permalink
  • Avatar
    Firewalla

    This is the article that talks about everything https://help.firewalla.com/hc/en-us/articles/115004292514-How-does-Firewalla-Intercept-Traffic-

     

    0
    Comment actions Permalink
  • Avatar
    Michael R. Houser Jr
    I always " arp spoofing" was a bad thing?
    0
    Comment actions Permalink
  • Avatar
    Firewalla

    with great power comes great responsibility ... probably fits better for 'arp spoofing'.   

    If you are disturbed about how gratuitous ARP (this is how arp spoofing is done) can route traffic, we also provide DHCP mode, which is an overlay that doesn't require arp packets.   And if you don't like overlay networks, you should get the Firewalla Gold, that one is an inline device (with an in and out). 

     

    0
    Comment actions Permalink

Please sign in to leave a comment.