Google Pixel monitoring

Comments

36 comments

  • Avatar
    TheLevin8r

    I really wish this issue was taken more seriously. It totally sucks that I can't monitor any of our Pixel phones.

    1
    Comment actions Permalink
  • Avatar
    TheLevin8r

    Firewalla, I'm the OP on this. I am now on a pixel 7 pro, with multiple family members and myself on many variants of pixels and 100% of them can not be monitored. I have a blue. Please don't patronize us with basic questions that have been all answered here get a pixel and test your platform. If you want to be taken seriously, do your own legwork.

    1
    Comment actions Permalink
  • Avatar
    Firewalla

    A few things to try

    1. tap on devices->tap on pixel->turn ON monitoring and turn ON emergency mode, and see if there is any difference.

    2. tap on devices->tap on pixel->turn OFF monitoring and turn ON emergency mode, and see if there is any difference. (I assume this is what you are running today)

    3. When you are at home, try to allocate a static IP to your pixel in the overlay network space, manually assigned an IP to it.  (your overlay is likely 192.168.218.x).  Then tap on devices->pixel->turn monitoring on and emergency off

     

    0
    Comment actions Permalink
  • Avatar
    TheLevin8r

    You are correct, my phone is set like 2 in Firewalla. I will try 1 this weekend, and 3 also. Can you explain the difference of how Firewalla handles a devices traffic with Monitored and Emergency both enabled, as opposed to Monitoring disabled?

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    Monitored: if you want firewalla to look at the device.  If it is off, firewalla is not in the picture and should not do any filtering.

    Emergency Mode: disables all rules and only leaves the "ingress firewall" on. 

    0
    Comment actions Permalink
  • Avatar
    Gilbert F Douglas, IV

    Hi, this issue has been plaguing my Pixel 6. Has there been any suggestions on fixing it??

    0
    Comment actions Permalink
  • Avatar
    David Rothenberger

    I have a Pixel 6 and have not had any problems with it maintaining a WiFi connection with my FWG. I'm using Unifi APs, if that matters.

     

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    @gilbert, are you in simple mode too?

    0
    Comment actions Permalink
  • Avatar
    Gilbert F Douglas, IV

    @David, I have 3 Pixel phones in my network, 2 Pixel 6's and 1 Pixel 5a.  Only one of the Pixel 6's seems to be affected, the other works fine.

     

    @Firewalla, my system is setup in simple mode.  When I manually set my Pixel 6 to the overlay network, monitoring seems to work without difficulty.  Likewise, disabling monitoring with keep the device connected to the SSID without difficulty.

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    Do you have any software running on that Pixel 6 that may be listening to the network? Simple mode uses arp spoofing, so if you pixel works, the other should work too. Unless, it is blocking arp requests ...

     

    0
    Comment actions Permalink
  • Avatar
    Gilbert F Douglas, IV

    I'm sorry, I'm a bit of a novice to some of these things. Can you suggest what type of software might block arp request?

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    Find antivirus or firewall type of apps on your phone. 

    0
    Comment actions Permalink
  • Avatar
    mark.munsell

    I'm having the same problem as well (connecting to wifi for a few seconds then auto disconnecting, repeatedly).  Brand new Pixel 6, android 12.  All other pixels that use the network do not have an issue. The  only way the new pixel 6 works is with FWG shut down (turned off).  I've tried just about every mode.  Also using simple mode.

     

    Edit -- turning off monitoring seemed to work, but using a VPN didn't, which is a bit confusing.  Regardless, these new Pixels appear have new security techniques to detect ARP spoofing and disconnect.

    0
    Comment actions Permalink
  • Avatar
    mark.munsell

    it appears that the 6 and 6 pro have many (somewhat unknown) security enhancements -- https://security.googleblog.com/2021/10/pixel-6-setting-new-standard-for-mobile.html -- might be worth checking into.

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    Does your pixel work with DHCP mode? That mode does not require arp spoofing.

    0
    Comment actions Permalink
  • Avatar
    Naoki Kojima

    My Pixel 4a (5G) output below log.

    2022-07-21 22:48:54.041 2577-18045/? W/IpClient.wlan0: [IpReachabilityMonitor] WARN ALERT neighbor: /192.168.1.1 MAC address changed from: 00:25:36:90:a3:a0 to: 02:01:ed:32:a4:ca
    2022-07-21 22:48:54.057 1740-1997/? I/EthernetTracker: interfaceLinkStateChanged, iface: wlan0, up: false

    I think Android is detecting the arp spoofing in the code below.

    https://cs.android.com/android/platform/superproject/+/master:packages/modules/NetworkStack/src/android/net/ip/IpReachabilityMonitor.java;l=420;bpv=1;bpt=1

    However, I don't understand why this problem is occurring only on some Pixels.

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    MAC address changes shouldn't kill the link state. The next messages says wlan0 is down ... which means wifi is down and detected. 

    0
    Comment actions Permalink
  • Avatar
    TheLevin8r

    Firewalla support,

    I'm the original poster to this thread. We got my wife a Pixel 6a, same issue. If I loaned you my factory reset Pixel 2, would you be willing to find the issue for us?

    0
    Comment actions Permalink
  • Avatar
    FrankP

    Since yesterday I have the same issue. My Phone (Pixel 7) was working without problems. Not sure if Google changed something but now it is kicking me out of monitoring every second. With emergency access no difference. With monitoring off it is not working. Any news on this old topic?
    Thx :-)

    0
    Comment actions Permalink
  • Avatar
    mark.munsell

    Yes, we had another Pixel in the house that had worked up until yesterday. Some kind of update caused this. Hopefully Firewalls will take this seriously and get a test Pixel and try to fix it

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    @frankp @mark.munsell

    Are you all running simple mode? or DHCP mode?

    And what do you mean by kicking you out of monitoring every second?  

    @mark.munsell, if you turn "off" monitoring of your pixel device, do you still have issues?

    0
    Comment actions Permalink
  • Avatar
    FrankP

    @Firewalla:

    I am in simple mode and "kicking out monitoring" is a typo. It is kicking me out of wireless network every second. 

    So the issue is the same as described already above. 

     

    0
    Comment actions Permalink
  • Avatar
    d.nollert

    I have the same issue since a very long time now. I even let Google replace my Pixel 6 because I thought my phone was faulty... But its the FWGold (simple mode), that is causing these interrupts from my local wifi. If I turn off the the FWG box, everything works as supposed. 

    Could you fix this please?

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    Thank you all! we are still trying to reproduce the issue, if you know the android version of the pixel, please let me know. 

    May I know if you tap on devices->[your pixel]->turn monitoring off, will this resolve the issue?

    Also, another is this

    Tap on +, tap on device port scan, and turn it off

     

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    Also, may I know if you are running bitdefender on your android, we know it may cause issues on windows if you have device port scan on

    0
    Comment actions Permalink
  • Avatar
    mark.munsell

    No Bitdefender, and yes if you turn monitoring off it resolves the issue

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    Hi Mark

    Do you have anything on your pixel, that's security-related, and can protect against ARP spoofing? (or an app updated with arp spoofing protection?) Simple mode, firewalla will arp spoof.

    0
    Comment actions Permalink
  • Avatar
    d.nollert
    • Android 13, (same issue on Android 12).
    • No Bitdefender
    • No other security related app installed on the phone
    • Nope, monitoring off does not help in my case
    • Adding Device port scan off does also not help my case

    Its only my Pixel 6 that has this problem.

    The only thing that helps is turning off the box.

    BR, David

    0
    Comment actions Permalink
  • Avatar
    mark.munsell

    No. This is something special the pixels have built in I think.

    0
    Comment actions Permalink
  • Avatar
    d.nollert

    I must correct my previous statement:

    Monitoring off + device port scan off seems to solve the wifi interruptions.

    0
    Comment actions Permalink

Please sign in to leave a comment.