Do batteries drain faster on Firewalla networks?

Comments

10 comments

  • Avatar
    Firewalla

    In theory, ARP packets should not wake up your phone.   So far we have not seen this happen. 

    But, about 2 years ago, we did have an Android bug where the Firewalla iOS app had a thread that never finishes ...  that was fixed 2 years ago as well.

    1. Are you running the firewalla app on the pixel? if you are try to kill it and see if it fixes the problem.

    2. Change the Google Pixel to unmonitored (under devices) and see if you have the same problem.

    3. Lastly tap on + and make sure port scan is off for LAN.

    1
    Comment actions Permalink
  • Avatar
    ajburgh

    I noticed the same thing when I installed my Blue Plus on my network. All battery powered Android phones and tablets saw a significant drop in battery life. At first I thought it was the Firewalla app on my phone, but that app is not on the tablet and work phone. After making those devices unmonitored battery life went back to normal, so it was not the app itself, but the monitoring part. 

    I would love to have a solution for this because I would like to turn monitoring back on for these devices. Would this be any different in DHCP mode? 

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    Tap on + and see if the "Device Port Scan" is active or not, that's a deeper scan of devices, not sure it will wake up the OS.  If you don't have that on (if you have that on, turn it off), please let us know the Android device versions you have, we spend a lot of time on this topic, and so far we have not seen one battery drain due to monitoring mode.  So we are curious about your particular problem. 

    0
    Comment actions Permalink
  • Avatar
    ajburgh

    The "Device Port Scan" was on. I will turn that off and turn monitoring back on and keep an eye on battery life. The devices are all on the latest android updates (Samsung S10E, Tab A7, Pixel 2XL and Pixel 3a XL). 

    I don't remember turning the Device Port Scan on. Is that on by default or did I turn that on in my initial playing around after installation?

    Thanks.

    0
    Comment actions Permalink
  • Avatar
    ajburgh

    I know it's been a while, but after I turned the device port scan off, it seemed to be a bit better. But there is still a noticeable reduction in battery life for my Android devices when monitoring in simple mode is turned on. 

    My work phone is sitting mostly idle on my desk and only gets used for some two-factor authorizations. This phone easily goes 4-5 days without charging. My Samsung tablet gets used occasionally, but is otherwise mostly idle. This lasts well over a week (probably 8-10 days of idle) on a charge. My personal phone gets a lot more use but typically lasts about a day and a half on a charge. This is with monitoring for these devices turned off.

    With monitoring turned on (but device port-scan off) I didn't notice the extra drain much on my personal phone because it is active more often, but I did notice that it was down to about 25% by the end of day, while it is otherwise around 40-50% when I put it on the charger at night. The difference was much more dramatic on the devices that are mostly idle. The Samsung tablet battery was dead within 3 days, while the work phone started battery conservation after 2 days.

    I turned monitoring back off and the battery life returned to normal. All devices are on their latest updates. Work phone (Samsung) is Android 9, Samsung tablet is Android 10, and personal Pixel phone is Android 11.

    I can live without the personal battery operated devices being monitored until I have time to setup the DHCP configuration, so it's not a big issue for me now that I now what is triggering it. I just wanted to provide an extra data point.

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    Is the problem appears to happen more often with Samsung?  One theory is this feature in some android phones wlan_rx_wake;  You can try to setup a static IP on your phones and see if it will make much difference.  Will ask our android developers to look at this and see if they can get their hands on a Samsung phone.

    0
    Comment actions Permalink
  • Avatar
    ajburgh

    No, the problem seems to be the same on the pixel (2 XL and 3a XL) phones. I will try a static IP instead of the fixed ip through DHCP that I have now, for a while to see if that makes a difference.

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    will pass this on to our developers.   

    0
    Comment actions Permalink
  • Avatar
    Christophe U

    I confirm the battery fast consumption (8 h instead of 2 days without usage) on Motorola G5 (one with firewalla app, the other one without) in Basic mode (ARP).

    A go back on 4G stop the fast consumption.

    I disabled "device scan" on phone group, it's perhaps a little bit better but not significative.
    I disabled "stop minitoring" on phone group and solve the trouble.

    0
    Comment actions Permalink
  • Avatar
    Firewalla

    @christophe, will it be possible to switch the firewalla to dhcp mode and see if it will be better? When in simple mode, arp spoofing is getting sent out to the phones, and we do know some phones may wake up and process this packet (while many don't). Want to see if this is the case.

    Yes, the device scan's will also send packets to the devices. (some will ignore these packets if they are sleeping, and some phones don't)

    0
    Comment actions Permalink

Please sign in to leave a comment.